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1. Introduction

MEZ® takes its name from the Muses of Greek mythology. A Muse was a goddess who inspired the creation process
for the arts and sciences. Like its ancient Greek namesake, the PEZ® platform inspires rapid development by
supplying customers with an extensive library of open source software, drivers, and processor support - all under a
common framework. LEZ® development works on the premise of “design once, reuse many times”. This provides
an open source standard for embedded developers to build upon and support. HEZ® allows companies to focus on
innovation and on their own value-added applications while minimizing development time and maximizing

software reuse.

The diagram below shows a typical embedded application stack. LEZ® has three primary categories of components
that help simplify embedded application development:

1. Operating System Abstraction Layer (nEZ® OSAL)
2. Sub-system drivers (0nEZ® TCP/IP, pEZ® USB, pEZ® Driver)
3. Hardware Abstraction Layer (nEZ® HAL)

Applications

wEZ® OSAL

uEZ® TCP/IP nEZ® DRIVER

Host . '-hCD
Device oucnscreen

File System
OTG 12C, SPI, Etc.

FreeRTOS™

uEZe HAL

‘ Hardware Peripheral API ’

Embedded Microprocessor ’

The selection of an RTOS can be one of the most daunting aspects of an embedded system development. With
MEZ® the primary features of common multi-tasking operating systems are abstracted, thus easing the transition to
an open source or low-cost RTOS. The HEZ® OSAL provides applications access to the following features in an OS-

independent fashion:

e Pre-emptive multitasking e Queues
e Stack overflow detection e Semaphores (binary, counting, mutex)
e Unlimited number of tasks

The MEZ® sub-system drivers utilize the OSAL functions to provide protected access to the processor
peripherals. The sub-system driver API functions are typically protocol layer interfaces (TCP/IP, USB, etc)
designed as high-level access routines such as open, close, read, write, etc. where possible.



The HAL functions provide single-threaded unprotected access to the processor peripherals. Customers can

use the MEZ® HAL routines provided by FDI or they can write their own. The HAL routines provide for

RTOS/MEZ® independence and allow portability within a family of processors.

MEZ® is ideally suited for Embedded Systems with standard features such as:

e Processor and Platform BSPs
(Board Support Packages)

e Real Time Operating System (RTOS)

e Memory Management

e NAND/NOR Flash

e SDRAM and DDR Memory

e TCP/IP stack

e USB Device/Host Libraries

e Mass Storage Devices

e LCD Displays with Touch Screen

e Input/ Output Devices

2. Downloading ugz’

Start by downloading the latest version of uEZ® from https://sourceforge.net/projects/uez/. Unzip to a working folder.

In this document we will use a simple directory structure of /uEZ but the user is free to modify this as desired.

The ukZ® file directory structure should be as follows:

Directory Description
/Build Projects/makefiles for different applications/demos
/Include UEZ® system files and Config.h

/Include/Device

Device Driver class definitions.

/Include/HAL

Hardware Abstraction Layer (HAL) driver class definitions.

/Include/Types

Common data types used by both HAL and Device Drivers.

/Source Source code

/Source/App User application source code and demos shared among
multiple builds.

/Source/BSP BSP generic startup code

/Source/Devices/<category>/<manufacturer>/<device>

Device specific code organized by category (12C, SSP, etc.),
manufacturer, and specific device.

/Source/Library/<category>/<package>

Various support libraries organized by category (graphics, file
system, etc.) and package name.

/Source/Platform/<manufacturer>/<platform>

Platforms/boards code organized by manufacturer and specific
platform build.

/Source/Processor/<manufacturer>/<processor>

Processor specific code in separate directories organized by
manufacturer and specific processor.

/Source/RTOS/<RTOS>/

RTOS source code in separate directories

/Source/uEZSystem

UEZ® System Core routines




3. Project Configuration

UEZ® uses a simple one project configuration. Depending on the compiler tools, use one of the following subsections.

Preparing the uEZ® Source Code
Download the uEZ® v1.11 (or later) source code from http://www.sourceforge.net/projects/uez. Unzip the file to where

you will be working. It should create a folder called /UEZ_SRC.

Rowley CrossWorks CrossStudio v2.0 Project Configuration
Check CrossStudio Version

UEZ® is built using v2.0, or later, of the Rowley CrossWorks CrossStudio for ARM® toolset. To confirm the version
number of the tools, go to Help->About in the main menu and the version number should appear in the middle of the
dialog.

Rowley
CrossWorks

Build versions of 2.0.x are acceptable.

Check Installed Packages
In addition, packages for your target processor(s) should be installed. Go to Tools->Show Installed Packages and see

which packages have been installed. For example,

Installed Packages

The following support packages have been installed, click on the links to get mare information on each package and its contents:

Paclkage Version Status
Generic ARM CPU Support Package 1.2 Installed
MXP LPC1000 CPU Support Package 1.7 Installed
MXP LPCZ000 CPU Support Package 1.30 Installed

If doing development for the DK-TS-KIT with the SOMDIMM-LPC2478, the following packages should be installed:
Generic ARM® CPU Support Package
NXP LPC2000 CPU Support Package

If doing development for the DK-TS-KIT with the SOMDIMM-LPC1788, the following packages should be installed:
Generic ARM® CPU Support Package



NXP LPC1000 CPU Support Package

If the packages are not installed, go to Tools->Download Packages from Web, download the missing packages, and then
use Tools->Install Package... to install them.

Opening and Compiling uez’

Open the one project build files in the /uEZ/Build directories. For example, when working on the DK-57TS-LPC2478,
open /uEZ/Build/DK-TS-KIT/CrossWorks 2.0/DK-57TS-LPC2478/DK-57TS-LPC2478 uEZDemo.hzp. The Project Explorer
should appear at the right showing all the files in the project. The uEZ distribution comes with the uEZ Demonstration
Application in the /uEZ/App/UEZDemo directory and is configured for the DK-57TS-LPC2478 kit.

To compile the code for the first time, select Build->Rebuild uEZ from the main menu. When complete, the output
should report “Build up to date” when done.

Downloading and Debugging uEZ® on the Target
1) Plug the J-Link device into the PC and install any drivers as directed. The Segger J-Link drivers can be found at

http://www.segger.com/cms/jlink-software.html with additional information at

http://www.segger.com/cms/development-tools.html.
2) Plug the J-Link’s JTAG cable into the target (e.g., SOMDIMM-LPC2478’s J3 connector).
3) Power on the target board.

4) Select Target menu and choose Targets. The following list will appear to the right.

:
2| % e
UUSB CrossConnect for ARM
USB CrossConnect for ARM-RTCK
F& Macraigor Wiggler (20 Pin)
FZ Macraigor Wigdler (14 Pin)
Olimex. ARM-USB-OCD
Olimex. ARM-USE-TINY
Amortec JTAGkey
*Verve Signalyzer
Luminary IJSE Debug
5TRY-comStick
Seqger J-Link

@ A

R Simulator

5) Right click on “Segger J-Link” and select Properties,

[55] 8 | G] e staoer ok Procees

[ Debug btednce Type: ARMITDH
2] Memcry Actess Teneout. 1000 millvacondy

&) Processor Byle Order. Ll
1 Frecnsser Stop Temeoue 500 miseconds

6) If this is the first time you are programming with the J-Link on the Rowley Platform, select J-Link DLL File, press
the “...” button and find the file JLinkARM.dII (usually installed in C:/Program Files/SEGGER/”)
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7) If programming a blank LPC2478 part, select a Speed of 100. If the LPC2478 has already been programmed,
select a Speed of 1000. All LPC2478’s that come with the DK-xTS-LPC2478 are pre-programmed.

8) Go back to menu Target and select “Connect Segger J-Link”

9) Press F5 to download the application to the target and start debugging. When the application starts, it will
pause. Press F5 again to start executing the code.

10) To stop at any line of code, right click the line and select Toggle Breakpoint. Execution will stop automatically at
the breakpoint. Press F5 again to continue debugging.

11) When done debugging, select Debug->Stop. The debugger will return to standard editor mode.

12) From this point on, the process is simply a matter of editing code, compiling the code (Build->Build ukEz or
pressing F7), and then running the debugger.

IAR Systems Embedded Workbench v6.10 Project Configuration

Check IAR Version
UEZ® is built using 6.10, or later, of the IAR Embedded Workbench Toolset. To confirm the version number of the tools,

go to Help->About->Product Info in the main menu and the version number should appear in the middle of the dialog.

Product Info

:}'@ |&F Embedded Waorkbench
Product details: _
| 11/4/2010 3:00:32 PM, 212992 bytes A
AR Archive Todl :

971.24(9.71.24)
C:%Program FileshAFR Systemz\Embedded Workbench B.0%armibintiarchive exe
10/29/20101:05:14 PM, 1529856 bytes

|&F Azsembler for AFRM
£.10.1.52143 [6.10.1.52143)
C:\Program FileghAR SystemshEmbedded Workbench B.0Marmbinhiasmarm, exe
10/29/2010 1:03:10 PM, 2451456 bytes

&R C/C++ Compiler for ARM
£.10.1.52143 (6.10.1.52143)
C:Program FileshAR Systemz\Embedded Workbench B.0%armbin\iccarm. exe
10/29/20101:09:18 PM, 25134080 bytes

|&F ELF Durnper faor ARM
£.10.1.52143(6.10.1.52143) e |

|i£ .
Copyright 2002-2010 [A4F Systems AB.

IAR C/C++ Compiler for ARM 6.10.1 and greater are acceptable.

Opening and Compiling uEZ®
Open the one project build files in the /uEZ/Build directories. For example, when working on the DK-57TS-LPC2478,

open UEZ\Build\DK-TS-KIT\DK-57TS-LPC2478\IAR6.10\ DK-57TS-LPC2478.eww. The Project Explorer should appear at
the left showing all the files in the project. The ukZ distribution comes with the uEZ Demonstration Application in the
JUEZ/App/ DK-TS-Demo directory and is configured for the DK-XXXTS-LPC2478 kit, in this case DK-57TS-LPC2478.

To compile the code for the first time, select Project->Make from the main menu or press F7. When complete, the
output should report “Total number of errors: 0” when done.



Downloading and Debugging uEZ® on the Target

1) Plug the J-Link device into the PC and install any drivers as directed. The Segger J-Link drivers can be found at

http://www.segger.com/cms/jlink-software.html with additional information at

http://www.segger.com/cms/development-tools.html.

2) Plug the J-Link’s JTAG cable into the target (e.g., SOMDIMM-LPC2478’s J3 connector).

3) Power on the target board.

4) The project is preconfigured for the Segger J-Link. If the J-link software is installed after IAR the dll will
automatically be updated. Otherwise run the SEGGER J-Link Updater from SEGGER/J-Link ARM vx.xx in the start

menu.

2 SEGGER J-Link DLL Updater ¥4.76h

The fallawing 3rd-party applications using JLinkARM.dll have been found

Select Al Select Mone

Select the ones you would like to replace by this version.

The previous version will be renamed and kept in the same folder, allowing manual "undo".
In case of doubt, da not replace existing DLL[s).

You can always perform thiz operation at a later time via start menu

[114R Embedded Woarkbench for ARM E.10 (DLL W4.28b in "C:\Program FilestAR SystemshEmbeddzd Workbench B.0%ARM bin')
[114R Embedded Workbench for ARM 6.10 (DLL W4.28b in "C:\Program FilesYAR SystemshEmbedded Woarkbench B.0_24WARMbIn"]

Ok Cancel |

5) Select Project->Download and Debug from the main menu or Ctrl + D to start debugging.

bedded Workbench IDE

View Nl Tools ‘window Help

Add Files. .
Add Group...

T

Edit Canfigurations. ..

57T

Includ  Create Mew Project...
Soyrg  Add Existing Project...
Ap
a0l

Options... AlL+F7
Fa(  Source Code Contral 3
U] Make F7
[ | Rebuild Al
Clean
Batch build, . F3

Download and Debug Chrl+D
Debug without Dawnloading

Download 3

L ™ Cvemrivaen Tanh

6) Debugging control can be operated from debug toolbar.
»>= =4 LD

7) When finished debugging press the red X in the debug toolbar.

X



4. Questions and Support

For all questions, bug reports and general technical support, go to https://sourceforge.net/projects/uez/ and use the

Sourceforge.net tools or email FDI directly at support@teamfdi.com . A support forum is also provided at

http://www.teamfdi.com/forum/ .

Marketing updates and details on technical support are available at www.teamfdi.com/uez .

Can we use another RTOS?

All LEZ® components are made to connect through the pEZ® OSAL (Operating System Abstraction Layer) to the RTOS
ensuring compatibility with many different RTOS's. Currently all LEZ® development by FDI is being focused on the
FreeRTOS™ platform since it satisfies the low cost tool requirement because it is “free”. RTOS products from other
vendors can also be used with HEZ®.

Which compiler suites do you support?
Currently, most HEZ® development by FDI has been focused on the low cost Rowley CrossWorks compiler, but we also
support the IAR EWARM tool suite. In addition, Keil, ARM® RealView, GNU and other compilers can be used with HEZ®.

What debug tools are available?
Since MEZ® uses the debug tools that are provided in the customers compiler suite, it can be used with any of the tools
listed above.

Which processors are supported?

Even though MEZ® is processor independent, all of our initial development has been focused on various members of the
ARM Family. We currently support the NXP LPC24xx family, the NXP LPC17xx, and processors like Cortex™-M3, and
other variations of ARM7® are being added.



