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FEATURES 
Supports the detection of UART 
UDP transfer capability 
ADPD103 full configuration 

Register level 
Parameter level 

Graph view 
Time graph 
Frequency graph 

EVALUATION KIT CONTENTS 
EVAL-ADPD103Z-GEN evaluation board 
Mini USB cable 

ADDITIONAL EQUIPMENT NEEDED 
PC running Windows 7 operating system 

ADDITIONAL SOFTWARE NEEDED 
.NetFramework 4.0 

ONLINE RESOURCES 
ADPD103 data sheet 

GENERAL DESCRIPTION 
The EVAL-ADPD103Z-GEN evaluation board provides the 
user with a simple means of connecting their own optics to the 
ADPD103 photometric front end to evaluate the ADPD103 in a 
number of different applications, from vital signs monitoring to 
industrial sensing. The evaluation board includes the OpenMarket 
WaveTool graphical user interface (GUI) that provides the user 
with low level and high level configurability, real-time frequency 
and time domain analysis, and User Datagram Protocol (UDP) 
transfer capability so that the evaluation board can easily interface 
to the user’s development system. 

The USB port powers the EVAL-ADPD103Z-GEN. On-board 
voltage regulators provide voltage supplies for the ADPD103, 
ADuCM360, and FTDI Chip FT232. There are on-board regulators 
that provide 3.3 V and 4.3 V LED supplies, as well as a selectable 
option to add an external LED supply. The evaluation board 
provides an LED and photodiode (PD) for a finger photo-
plethysmography (PPG) measurement that is useful for a quick 
functionality check of the evaluation system. 

The schematic and board layout, as well as the board itself, 
indicate signal names for easy identification. For additional 
information on the functionality of the ADPD103, refer to the 
ADPD103 datasheet. 

EVALUATION BOARD PHOTOGRAPH 
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Figure 1. EVAL-ADPD103Z-GEN Evaluation Board 
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INSTALLATION 
INSTALL WAVETOOL 
Download the ADPD103 OpenMarket WaveTool software 
package from the EVAL-ADPD103Z-GEN page on analog.com. 
Unzip the folder and run the ADPD103_OpenMarket_ 
WaveTool_Setup.exe file found in the WaveTool_x_x_x folder, 
following the prompts for software installation. 
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Figure 2. WaveTool Setup 

 

 

CHECKING THE USB SERIAL CONNECTION IN 
WINDOWS 7 
Connect the USB cable to the EVAL-ADPD103Z-GEN 
evaluation board. Ensure that the COM port driver is installed 
correctly. To verify proper installation, go to Control Panel > 
All Control Panel Items > System > Device Manager, as 
shown in Figure 3. In this case, the proper COM Port selection 
is USB Serial Port (COM16). 

The EVAL-ADPD103Z-GEN evaluation board uses an FT-232R 
USB UART IC. If the USB driver installation does not install 
properly, refer to the FTDI Driver Installation guide found on 
the FTDI website.  

 
Figure 3. USB-COM Port in Windows® 7 
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RUNNING THE TOOL 
To start the WaveTool application, navigate to the ADPD103 
OpenMarket WaveTool from the Start menu and click 
ADPD103_Tool.  
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Figure 4. Navigate to ADPD103_Tool from Start Menu 

At startup, the application automatically checks whether the 
installed WaveTool version is up to date. If there is a newer 
version available, the user is prompted to download the new 
version, as shown in Figure 5.  
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Figure 5. Automatic Version Update Prompt 

USB UART CONNECTION 
After the application opens, select File > Connect (see Figure 6) 
and from the drop-down menu, select either Auto Connect or 
Select Port, depending on whether specific COM port selection 
is necessary.  
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Figure 6. UART Connect 

If a specific COM port selection is not needed, select Auto 
Connect to automatically connect the WaveTool to the device. 
Choose Select Port to connect the WaveTool to the device via a 
particular COM port as shown in Figure 7.  
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Figure 7. Port Selection 
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MAIN SCREEN 
The main screen is divided into two different modes: register 
level and parameter level/high level.  

The register level configuration is used to access each register or 
to load a complete list of registers that are already stored in a 
configuration file on the PC. 

The parameter level/high level configuration performs a high 
level configuration of the device without the need for individual 
register writes. The high level configuration screen is used to 
setup parameters such as LED current, number of LED pulses, 
AFE integration time, and so forth. 

USING THE REGISTER VIEW CONFIGURATION 
Figure 8 shows the ADPD configuration window in Register 
View. The following controls and descriptions are listed in the 
configuration window: 

• Firmware Version—shows the firmware version.  
• Config File in Use—information about the configuration 

file that is in use. 

• Register View shows the current register values of the 
device. Change register values by entering a hexadecimal 
value and then the Enter key on the keyboard. 

• Register Field View shows how the register is subdivided 
into fields that determine how each bit field is used. For 
example, in Figure 8 it shows that the PAD_IO_CTRL 
Register 0x02 is composed of the bit fields INT_POL, 
INT_DRV, and INT_ENA to configure the operation of the 
INT pin.  

• The Single Register Control allows reading and writing of 
individual registers. 

• Load a configuration file (.dcfg) by choosing File > 
LoadCfg and selecting a .dcfg file that came with the 
software installation or a custom .dcfg file developed by the 
user for a desired configuration. 

• Save a configuration file (.dcfg) by choosing File > SaveCfg. 
• The Go to High Level button switches to the High Level 

Control view. 
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Figure 8. Main Screen Register Level View 
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Register View 

To view the registers of the device, select Register View, shown 
in Figure 8. The Name column is the register name as defined 
by the register map, followed by (in parentheses) the address in 
abbreviated hexadecimal format (see Figure 9). The Value 
column shows the register value of the corresponding register in 
full hexadecimal format. 
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Figure 9. Register View 

Clicking any register in the Register View fields reveals the 
register categories in the Register Field View, as shown in 
Figure 10. The Register Field View is read only.  
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Figure 10. Register View Showing Operation Control Registers 

 

 

Enter data in cells in the Value column of the Register View in 
either hexadecimal or decimal format. A hexadecimal number is 
entered with a 0x prefix to the number, whereas a decimal 
number does not include these prefix characters. For example, 
entering 0xFF (hexadecimal) or 255 (decimal), results in the 
same value written to the register. 

Hovering over a cell in the Value column shows the delineation 
of the register fields for the current value (see Figure 11), 
whereas hovering over a cell in the Name column shows a 
description of the corresponding register. 
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Figure 11. Register Value Field Delineation on Hover 

The Register View has a context sensitive window exposed by 
right-clicking the mouse anywhere on the grid, as shown in 
Figure 12. 
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Figure 12. Register View Context Menu 

By using this menu, it is possible to refresh the selected register, 
refresh all registers, or select whether the selected register 
displays in hexadecimal or decimal format. The selection of 
hexadecimal vs. decimal is persistent across opening and 
closing of the tool.  

For example, in Figure 13, the Time Slot B offset registers 
(CHx_OFFSET_B) display in decimal format but others, such 
as LED drive settings (LEDx_DRV), display in hexadecimal 
format. 

 
Figure 13. Register Values in Decimal and Hexadecimal Format 
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Register Field View 

The Register Field View is a read-only view to see specific 
register field value(s). It automatically tracks the currently 
selected register in Register View. 

The Register Field View is composed of two columns as shown 
in Figure 14. 
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Figure 14. Register Field View 

 
 

 

 

 

 

 

The Register Field View section shows each register field, 
where the Name column consists of the field name (start bit: 
length in bits), and the Value column provides the hexadecimal 
value (without the prefix characters, 0x) of that field . 

Single Register Control 

The Single Register Control section includes controls to read 
or write an individual register. 

The Read Register button reads and displays the value of the 
register entered in the Register Address field. 

The Write Register button writes the register with the value 
entered in the Register Value field. 
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Figure 15. Single Register Control 
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PARAMETER LEVEL (HIGH LEVEL) 
Figure 16 shows the ADPD103 high level configuration window. 
This window offers an entire set of high level parameter 
controls. The configurable parameters are as follows:  

• Sampling Frequency—adjusts the sampling rate. 
• Internal Average (identical for both slots)—controls the 

output data rate, which is equal to the sampling frequency 
divided by the internal average. For example, a sampling 
frequency of 400 Hz and an internal average setting of 4, as 
shown in Figure 16, results in an output data rate of 100 Hz.  

• ADPD Slot Mode—specifies all the ADPD slot modes. 
• Slot A Control and Slot B Control 

• LED Control 
• LED—selects the specific LED from a drop-down 

menu. 
• LED Status—specifies the status of the LED, 

whether it is in the on or off state. 
• Number Of Pulses—sets the number of LED 

pulses. 
• TIA Gain—sets the gain of the TIA via a drop-down 

menu. 
• Timing Control—see the ADPD103 datasheet for 

detailed descriptions of the timing controls. 

• AFE Width—sets the AFE integration time in 
microseconds. 

• Pulse Width—sets the LED pulse width in 
microseconds. 

• Pulse Offset—sets the LED pulse offset in 
microseconds. 

• AFE Offset—sets the coarse AFE integration offset 
in microseconds. 

• AFE Fine Offset—sets the fine AFE integration 
offset in nanoseconds. 

• LED 1, LED 2, LED 3 current controls  
• I_LED Coarse—coarse setting for the LED current 

via a drop-down menu. 
• Scale Factor—100% or 40% scale factor applied to 

the coarse LED current setting. 
• Final I_LED—this is controlled by applying a fine 

tuning value by using the slider. The Final I_LED 
current displays in mA. 

To switch to the register level configuration, click the Go to 
RegisterLevel button. 
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Figure 16. Main Screen High Level View 
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ADPD SLOT MODE 
The ADPD slot mode contains Slot A, Slot B, and their sum and 
digital integration modes. 
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Figure 17. ADPD Slot Mode 

Slot A (16 Bits) 

The 4-channel, 16-bit data displays in the Time View for Time 
Slot A only. Selected channel data in the Channel Select drop-
down box displays in FFT view. 

Slot B (16 Bits)  

The 4-channel, 16-bit data displays in the Time View for Time 
Slot B only. Selected channel data in the Channel Select drop-
down box displays in FFT view. 

Slot AB (16 Bits)  

The 4-channel, 16-bit data displays in the Time View for both 
Time Slot A and Time Slot B. Selected channel data in the 
Channel Select drop-down box displays in FFT view. 

Slot A (32 Bits)  

The 4-channel, 32-bit data displays in the Time View for Time 
Slot A only. Selected channel data in the Channel Select drop-
down box displays in FFT view. 

Slot B (32 Bits)  

The 4-channel, 32-bit data displays in the Time View for Time 
Slot B only. Selected channel data in the Channel Select drop-
down box displays in FFT view. 

Slot AB (32 Bits)  

The 4-channel, 32-bit data displays in the Time View for both 
Time Slot A and Time Slot B. Selected channel data in the 
Channel Select drop-down box displays in FFT view. 

Slot A Sum (16 Bits) 

The sum of 4-channel, 16-bit data displays in the Time View for 
Time Slot A only. Selected summation sample data in the 
Channel Select drop-down box displays in FFT view. 

Slot B Sum (16 Bits) 

The sum of 4-channel, 16-bit data displays in the Time View for 
Time Slot B only. Selected summation sample data in the 
Channel Select drop-down box displays in FFT view. 

Slot AB Sum (16 Bits) 

The sum of 4-channel, 16-bit data displays in the Time View for 
both Time Slot A and Time Slot B. Selected summation sample 
data in the Channel Select drop-down box displays in FFT 
view. 

Slot A Sum (32 Bits) 

The sum of 4-channel, 32-bit data displays in the time view for 
Time Slot A only. Selected summation sample data in the Channel 
Select drop-down box displays in FFT view. 

Slot B Sum (32 Bits) 

The sum of 4-channel, 32-bit data displays in the Time View for 
Time Slot B only. Selected summation sample data in the Channel 
Select drop-down box displays in FFT view. 

Slot AB Sum (32 Bits)  

The sum of 4-channel, 32-bit data displays in the Time View for 
both Time Slot A and Time Slot B. Selected summation sample 
data in the Channel Select drop-down box displays in FFT 
view. 

Slot A Dig Int-1 (16-Bits) 

16-bit digital integrated sample data displays in the Time View 
for Time Slot A only. Selected sample data in the Channel Select 
drop-down box displays in FFT view. 

Slot B Dig Int-1 (16 Bits) 

16-bit digital integrated sample data displays in the Time View 
for Time Slot B only. Selected sample data in the Channel Select 
drop-down box displays in FFT view. 

Slot AB Dig Int-1 (16 Bits) 

16-bit digital integrated sample data displays in the Time View 
for Time Slot A and Time Slot B. Selected sample data in the 
Channel Select drop-down box displays in FFT view. 

Slot A Dig Int-2 (16 Bits)  

16-bit digital integrated sample and background data displays in 
the Time View for Time Slot A only. Selected sample or back-
ground data in the Channel Select drop-down box displays in 
FFT view. 
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Slot B Dig Int-2 (16-Bits) 

16-bit digital integrated sample and background data displays in 
the Time View for Time Slot B only. Selected sample or back-
ground data in the Channel Select drop-down box displays in 
FFT view. 

Slot AB Dig Int-2 (16 Bits) 

16-bit digital integrated sample and background data displays in 
the Time View for Time Slot A and Time Slot B. Selected sample or 
background data in the Channel Select drop-down box displays 
in FFT view. 

Slot A Dig Int-1 (32 Bits) 

32-bit digital integrated sample data displays in the Time View 
for Time Slot A only. Selected sample data in the Channel Select 
drop-down box displays in the FFT view. 

Slot B Dig Int-1 32 Bits:  

32-bit digital integrated sample data displays in the Time View 
for Time Slot B only. Selected sample data in the Channel Select 
drop-down box displays in the FFT view. 

Slot AB Dig Int-1 (32 Bits) 

32-bit digital integrated sample data displays in the Time View 
for Time Slot A and Time Slot B. Selected sample data in the 
Channel Select drop-down box displays in the FFT view. 

Slot A Dig Int-2 (32 Bits) 

32-bit digital integrated sample and background data display in 
the Time View for Time Slot A only. Selected sample or back-
ground data in the Channel Select drop-down box display in 
the FFT view. 

Slot B Dig Int-2 (32 Bits) 

32-bit digital integrated sample and background data display in 
the Time View for Time Slot B only. Selected sample or back-
ground data in the Channel Select drop-down box display in 
the FFT view. 

Slot AB Dig Int-2 (32 Bits)  

32-bit digital integrated sample and background data display in 
the Time View for Time Slot A and Time Slot B. Selected sample or 
background data in the Channel Select drop-down box display 
in the FFT view. 

LOAD AND SAVING CONFIGURATIONS 
To load and save device configuration files use File > Load Cfg 
and File > Save Cfg, respectively, as shown in Figure 18 and 
Figure 19. Load configuration (Load Cfg) loads the set of 
registers mentioned in the user selected .dcfg file to ADPD103. 
Save configuration (Save Cfg) saves all writable registers of 
ADPD103 to a .dcfg file via the Open file dialog box. 

Find sample configuration files installed with the WaveTool 
application in the SampleCfgs folder.  
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Figure 18. Load Configuration 
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Figure 19. Save Configuration 

Selecting Load Cfg opens up a file dialog window. Device 
configuration files have the extension .dcfg. Once loaded, the 
configuration file used by the evaluation board is indicated in 
the main window, as shown in Figure 20. The full path of 
the .dcfg file is shown when the mouse hovers over the file 
name. If no file is loaded, then it is indicated as None. 
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Figure 20. Configuration File in Use 

A configuration file uses the following format: 
Address Data #(comment optional) 
Where the address can be an in 8-bit or 16-bit format and the 
data must be in 16-bit format, as follows: 
14 0555 #setup input PD configuration 

15 0220 #number of averages = 4 

18 1F80 #slot A channel 1 ADC offset 

19 1F80 #slot A channel 2 ADC offset 

http://www.analog.com/ADPD103?doc=EVAL-ADPD103Z-GEN-UG-947.pdf
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APPLY CONFIGURATION 
A previously loaded configuration remains in the memory of 
the tool until overwritten by a new load configuration 
(LoadCfg). Therefore, to return to a loaded configuration 
quickly, it is not necessary to reload the configuration, instead 
select File > Apply Config. 
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Figure 21. Apply Configuration 

DUMP REGISTERS 
With the tool, it is possible to dump all the registers to a single 
file by selecting File > Register Dump, as shown in Figure 22.  
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Figure 22. Dump Register 

Registers are dumped into a text file with a filename given by 
the user upon opening the File dialog box, a window that 
prompts the user to save the file to a specific location with a 
specific name. 

The following is an example of a register dump: 
PD_SELECT (14) 0555 

INT_AVG_MODE (15) 0220 

CH1_OFFSET_A (18) 1F80 

CH2_OFFSET_A (19) 1F80 

Note that, the register is listed by name (address in hexadecimal 
value). 
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GRAPH VIEW 
Use Graph View or real-time frequency and time domain 
analysis of the ADPD103 raw data. Access Graph View from the 
main window via the View menu tab, as shown in Figure 23. 
When the Graph View opens, it defaults to the time domain 
view (Time View) as shown in Figure 24. There is also a 
Frequency View tab for frequency domain analysis. 
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Figure 23. View Menu 
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Figure 24. Time View 

http://www.analog.com/ADPD103?doc=EVAL-ADPD103Z-GEN-UG-947.pdf
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Time View 

Time View displays the raw data from the sensor in time 
domain format. Plot or send the raw data through the UDP 
protocol to the host system that is controlled by a checkbox in 
the Time View, which has three controls:  

• UDP on/plot off, where the UDP Transfer checkbox is
checked (see Figure 25).
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Figure 25. UDP On/Plot Off Mode 

• UDP off/plot on, where the UDP Transfer checkbox is not
selected (see Figure 26).
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Figure 26. UDP Off/Plot On Mode 

• UDP on/plot on, where the UDP Transfer checkbox fill is
solid (see Figure 27).
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Figure 27. UDP On/Plot On Mode 

In UDP on mode, the data is sent through UDP and does not 
display in the graph panel. 

In UDP off/plot on mode, the data displays in the graph panel 
but is not sent through the UDP. 

In UDP on/plot on mode, the data is sent through UDP and 
also displays in the graph panel. 

The UDP Transfer Tool, a separate executable within the 
WaveTool package, receives the data from WaveTool and 
transfers the data to the assigned UDP port. 

To save the raw data into a file, check the Save Raw Data 
checkbox, as shown in Figure 28. When the box is checked, the 
user is prompted to save the file. 

Figure 28. Checkbox to Save Sensor Raw Data to a File 

Configure the x-axis sample count for graph plotting through 
the X-Axis Sample Counts field (see Figure 29). 
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Figure 29. X-Axis Sample Count Configuration 

Note that, the minimum value for sample count is limited to 
100. If it is assigned with values smaller than 100, it 
automatically corrects to 100. 

Time View shows the raw data graph that plots Sample (index) 
vs. LSBs data. 

The plot of each individual channel is controlled using the 
checkboxes as shown in Figure 30. 
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Figure 30. Channel Display Control 

By clicking the checkbox the corresponding channel data is 
plotted with the specified color in the Raw Data graph. 

The auto scaling of the time graph view can be enabled/disabled 
by a checkbox present at the bottom of the time graph. Also the 
minimum and maximum scale range can be adjusted while the 
auto scale option is disabled. 
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Figure 31. Auto Scale Control and Scale Range Setting 

The average and standard deviation for every channel and sum 
of all channels are displayed along the bottom of the time graph 
view. These statistics are enabled or disabled by the checkbox 
preceded by each label as shown in Figure 32. 
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Figure 32. Average and Standard Deviation Display 
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General Controls 

Using standard controls, the user can start (see Figure 33), stop 
the current mode and return to idle mode (see Figure 34), and 
pause the device in its current operating state (see Figure 35) 
whereby graphs are no longer updated but data is still retrieved 
from the device.  
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Figure 33. Start Icon 
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Figure 34. Stop and Return to Idle Icon 
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Figure 35. Pause and Resume Icon 

FREQUENCY VIEW 
Frequency View shows the fast fourier transform (FFT) of the 
raw data in the form of a graph that plots amplitude vs. 
frequency (Hz). The user can select the x-axis scale type as 
linear or logarithmic in the XAxis Scale Type drop-down list, 
as shown in Figure 36. 
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Figure 36. X-Axis Scale Type 

The FFT Samples field provides the number of samples used to 
calculate the FFT.  
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Figure 37. FFT Samples 

Note: The minimum value for sample count is limited to 50 
samples. If it is assigned with values smaller than 50, it 
automatically corrects to 50. 

The Frequency View displays any one of the enabled channels 
from the Channel Select drop-down list. For example, if Slot A 
is enabled, the user can select any one channel of Slot A, as 
shown in Figure 38. 
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Figure 38. Slot A Channels 

The linear scale of the FFT graph is shown in Figure 39 and the 
logarithmic scale of FFT graph is shown in Figure 40. 
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Figure 39. Linear FFT Graph 
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Figure 40. Logarithmic FFT Graph
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TOOLS 
OPTIONS 
The Options selection from the Tools drop-down menu shows 
the general board settings as well as the UDP configuration. 

General 

The General tab contains information about the device, the 
platform, and the firmware version. 
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Figure 41. Options Window: General 

UDP Configuration 

The UDP Configuration tab allows the user to configure the 
port numbers for UDP communication. The UDP transfer tool 
sends the raw data to the client via the specified port numbers. 
The IP address field should be filled with the IP address in 
which the UDP transfer tool is running. 

Use the Raw Data Transfer Port field to assign the port number 
for sending raw data from WaveTool to the data transfer tool. 
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Figure 42. Options Window: UDP Configuration 

AUTOMATIC UPDATE 
The Tools > Auto Update function enables/disables the 
automatic software update functionality at the time of tool start. 
When Auto Update is enabled, it checks for the availability of a 
new WaveTool update and prompts the user to update the tool 
with the latest version. 
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Figure 43. Auto Update 

CHECK FOR UPDATES 
Use the Tools > Check For Updates function to manually check 
for the availability of a new software update. 
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Figure 44. Check for Update 

FIRMWARE UPDATE 
Note: The WaveTool must be connected with the target board to 
perform the firmware update; otherwise, the WaveTool shows a 
disconnect message (see Figure 45). 
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Figure 45. Connection Status for Firmware Update 

Use the Tools > Firmware Update function to start the 
firmware update process. 
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Figure 46. Firmware update 

When Firmware Update is selected, the CM3WSD firmware 
flashing tool opens. 
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To flash the firmware, the user must ensure that the correct 
path and filename are selected in the file dialog box, as shown 
in Figure 47.  
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Figure 47. Firmware Flashing Tool 

With the correct path/filename entered and the correct USB 
serial port selected, click Start. The user is then prompted to 
pulse the Reset button while holding down the Download 
button on the evaluation board (circled in Figure 48). The 
firmware download starts when this step is completed. 
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Figure 48. Serial Download and Reset Buttons to Flash Firmware 

When the firmware download has completed, click Reset in the 
CM3WSD window and then Exit. The user can now return to 
the WaveTool and reconnect the device via File > Connect to 
commence testing with the updated firmware. 

SEND REPORT 
If the software update failed for ten times continuously, it opens 
the pop-up window shown in Figure 49. 
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Figure 49. Report Alert 

When the user clicks Yes, another window appears (see Figure 50). 
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Figure 50. Email Window 

Enter your name in the Enter Your Name field and your user 
email ID (this is the email address you used when registering to 
receive the software package) in the Enter Your Email ID field. 
After entering your user name and email ID, click Send to 
initiate the report to Analog Devices. 
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EXITING APPLICATION 
There is a two-step process to exit the application. 

1. Disconnect the device via File > Disconnect Ctrl+D, as
shown in Figure 51.
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Figure 51. Disconnect 

2. Exit via File > Exit, as shown in Figure 52.
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Figure 52. Exit 
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UDP TRANSFER TOOL 
This section explains the raw data reception and its data format for 
various modes from the UDP transfer tool over UDP protocol. 

UDP TRANSFER TOOL SETUP 
To setup the UDP transfer tool, follow these steps: 

1. Open WaveTool and go to Tools > Options > UDP 
Configuration. Enter the IP address of the remote
machine where the UDP transfer tool is running.

14
32

1-
05

0

Figure 53. UDP Configuration 

2. Connect the hardware (File > Connect > Auto Connect or
File > Connect > Select Port) using the UART bridge on
the host machine.
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Figure 54. Connection 

3. Open Graph View and check the UDP Transfer box in the
Time View tab.
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Figure 55. Enable UDP Transfer 

4. Click the play button to send the raw data through the
UDP protocol.

To save the raw data being transferred via UDP to a data file, 
open the receiver tool (UDPTransferTool.exe) and enter the IP 
address of the system. 
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Figure 56. UDP Receiver Tool 

1. Enter the file name to save the raw data from WaveTool
and press enter.
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Figure 57. Decision to Continue or Stop 

2. The received packet count is continuously displayed in the
tool and the raw data is stored in the file.
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Figure 58. Receiving Raw Data 

3. Press the ESC key to stop receiving the data and close the
current file.
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Figure 59. Closing the File 

RAW DATA FORMAT 
Before using the UDP transfer tool, ensure that WaveTool is 
opened and running with UDP transfer enabled. See Figure 60 
for an example of stored sample raw data. 
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Figure 60. Sample Data 

The sample data transmits in the form of ASCII bytes. The 
sample data format is as follows: 
F0136CFC0000000FE90000105000000EA000000FCC 

• The first two characters (F0) represent sync.
• Next two characters (13) represent size.
• Next two characters (6C) represent sequence number.
• Next four characters (FC00) represent time stamp.
• The remaining characters represent the hexadecimal

channel raw data and its count (based on the slot modes of
the WaveTool).

Table 1. UDP Data Format 
F0 13 6C FC00 00000FE9 0000105000000EA000000FCC 
Sync (2) Size (2) Sequence number (2) Time stamp (4) Raw data 

Table 2. UDP Data Count for Various Modes 
Slot Mode Data Format Data Count 
Slot A Sum, 16 Bits 00000FE9 1 
Slot B Sum, 16 Bits 
Slot A Sum, 32 Bits 
Slot B Sum, 32 Bits 
Slot A Dig Int, 16 Bits 
Slot B Dig Int, 16 Bits 
Slot AB Sum, 32 Bits 00000FE9 00001050 2 
Slot A Dig Int, 32 Bits 
Slot B Dig Int, 32 Bits 
Slot A, 16 Bits 00000FE9 00001050 00000EA0 00000FCC 4 
Slot B, 16 Bits 
Slot A, 32 Bits 
Slot B, 32 Bits 
Slot AB, 16 Bits 00000F7E 0000105C 00000EA8 00000FCC 00000FE9 00001064 00000EAD 00000FCE 8 
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UDP CONTROLLER TOOL 
Open the UDP controller tool (see Figure 61) and complete the 
Enter your Host IP Address field. This is the IP address of the 
system where the WaveTool is running. 

After entering the corresponding IP address, the user can send and 
receive commands between the controller and the WaveTool. 
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Figure 61. UDP Controller 

UDP CONTROLLER APPLICATION TESTING 

PROCEDURE 
Port Connection 

To use the read register or write register functions, the port 
must be connected in the OpenMarket WaveTool. Connect the 
port using the following steps: 

1. Open the ADPD103 OpenMarket WaveTool application.
2. Connect the port. From File > Connect select either

a. Auto Connect (to automatically select the port) or
b. Select Port (to manually select the port).

3. Ensure the UDP control IP address is assigned correctly.

Read Register 

After connecting to the port, send the register read command as 
00 01 <reg address>, for example, send as 00 01 01 to read from 
register 0x01.  

00 = register read command 
01 = number of parameters 
01 = register address 

The response is received with the register value. 
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Figure 62. Read Register Operation 

http://www.analog.com/ADPD103?doc=EVAL-ADPD103Z-GEN-UG-947.pdf
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Write Register 

After connecting the port following the instructions in the Port 
Connection section, send the register write command as 00 03 
<reg address> <Value>, for example, send as 00 03 01 00 01, 
where 

00 = register write command 
03 = number of parameters 
01 = register address 
00 01 = register value 

The response is received with the register value. 
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Figure 63. Write Register Operation 
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Run 

Open the ADPD103 OpenMarket WaveTool application and 
connect the port (see the Port Connection section). If bridge is 
connected, then open the graph view: View > Graph. 

Next, send the play command as 02 00, where 

02 = play command 
00 = number of parameters 

Stop 

Open the ADPD103 OpenMarket WaveTool application and 
connect the port (see the Port Connection section). If bridge is 
connected, then open the graph view: View > Graph. 

Next, send the stop command as 03 00, where 

03 = stop command 
00 = number of parameters 

Load Configuration 

Open the ADPD103 OpenMarket WaveTool application and 
connect the port (see the Port Connection section). If bridge is 

connected, then a command can be sent to WaveTool through 
the UDP. 

Next, send the load configuration file command as 0D 00, 
which gives a list of available configuration file names as shown 
in Figure 64.  

Select the particular configuration file using the following 
command, based upon which configuration from the list is to 
be loaded. For example, 0D 01 (01/02/03......./07). 

Likewise, commands can be given for connect, disconnect, 
open view, and raw data by referring to the command list in 
Table 3. 

COMMANDS SUMMARY 
Table 3 summarizes the list of commands, command code and 
example formats for various functions that are currently 
available in the WaveTool. 

Table 3. Commands Summary 
Command Command Code1 Example 
Connect 0A 00 0A 00 
Disconnect 0B 00 0B 00 
Open View 0C 00 0C 00 
Load Configuration (Load Cfg) 0D 00 0D 00 
Read 00 01  

<reg address> 
00 01 40 

Write 01 03  
<reg address> <Value> 

01 03 41 00 01 

Run 02 00 02 00 
Stop 03 00 03 00 
Raw Data 06 01 <ON/OFF> 06 01 01 (or) 06 01 00 

1 See Figure 61. 
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Figure 64. List of .dcfg Files Available in WaveTool Configuration Directory 

ESD Caution  
ESD (electrostatic discharge) sensitive device. Charged devices and circuit boards can discharge without detection. Although this product features patented or proprietary protection 
circuitry, damage may occur on devices subjected to high energy ESD. Therefore, proper ESD precautions should be taken to avoid performance degradation or loss of functionality. 

Legal Terms and Conditions 
By using the evaluation board discussed herein (together with any tools, components documentation or support materials, the “Evaluation Board”), you are agreeing to be bound by the terms and conditions 
set forth below (“Agreement”) unless you have purchased the Evaluation Board, in which case the Analog Devices Standard Terms and Conditions of Sale shall govern. Do not use the Evaluation Board until you 
have read and agreed to the Agreement. Your use of the Evaluation Board shall signify your acceptance of the Agreement.  This Agreement is made by and between you (“Customer”) and Analog Devices, Inc. 
(“ADI”), with its principal place of business at One Technology Way, Norwood, MA 02062, USA. Subject to the terms and conditions of the Agreement, ADI hereby grants to Customer a free, limited, personal, 
temporary, non-exclusive, non-sublicensable, non-transferable license to use the Evaluation Board FOR EVALUATION PURPOSES ONLY. Customer understands and agrees that the Evaluation Board is provided 
for the sole and exclusive purpose referenced above, and agrees not to use the Evaluation Board for any other purpose. Furthermore, the license granted is expressly made subject to the following additional 
limitations: Customer shall not (i) rent, lease, display, sell, transfer, assign, sublicense, or distribute the Evaluation Board; and (ii) permit any Third Party to access the Evaluation Board. As used herein, the term 
“Third Party” includes any entity other than ADI, Customer, their employees, affiliates and in-house consultants. The Evaluation Board is NOT sold to Customer; all rights not expressly granted herein, including 
ownership of the Evaluation Board, are reserved by ADI. CONFIDENTIALITY. This Agreement and the Evaluation Board shall all be considered the confidential and proprietary information of ADI. Customer may 
not disclose or transfer any portion of the Evaluation Board to any other party for any reason. Upon discontinuation of use of the Evaluation Board or termination of this Agreement, Customer agrees to promptly 
return the Evaluation Board to ADI. ADDITIONAL RESTRICTIONS. Customer may not disassemble, decompile or reverse engineer chips on the Evaluation Board. Customer shall inform ADI of any occurred 
damages or any modifications or alterations it makes to the Evaluation Board, including but not limited to soldering or any other activity that affects the material content of the Evaluation Board. Modifications to 
the Evaluation Board must comply with applicable law, including but not limited to the RoHS Directive. TERMINATION. ADI may terminate this Agreement at any time upon giving written notice to Customer. 
Customer agrees to return to ADI the Evaluation Board at that time. LIMITATION OF LIABILITY. THE EVALUATION BOARD PROVIDED HEREUNDER IS PROVIDED “AS IS” AND ADI MAKES NO WARRANTIES OR 
REPRESENTATIONS OF ANY KIND WITH RESPECT TO IT. ADI SPECIFICALLY DISCLAIMS ANY REPRESENTATIONS, ENDORSEMENTS, GUARANTEES, OR WARRANTIES, EXPRESS OR IMPLIED, RELATED TO THE 
EVALUATION BOARD INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTY OF MERCHANTABILITY, TITLE, FITNESS FOR A PARTICULAR PURPOSE OR NONINFRINGEMENT OF INTELLECTUAL PROPERTY 
RIGHTS. IN NO EVENT WILL ADI AND ITS LICENSORS BE LIABLE FOR ANY INCIDENTAL, SPECIAL, INDIRECT, OR CONSEQUENTIAL DAMAGES RESULTING FROM CUSTOMER’S POSSESSION OR USE OF THE 
EVALUATION BOARD, INCLUDING BUT NOT LIMITED TO LOST PROFITS, DELAY COSTS, LABOR COSTS OR LOSS OF GOODWILL. ADI’S TOTAL LIABILITY FROM ANY AND ALL CAUSES SHALL BE LIMITED TO THE 
AMOUNT OF ONE HUNDRED US DOLLARS ($100.00). EXPORT. Customer agrees that it will not directly or indirectly export the Evaluation Board to another country, and that it will comply with all applicable 
United States federal laws and regulations relating to exports. GOVERNING  LAW. This Agreement shall be governed by and construed in accordance with the substantive laws of the Commonwealth of 
Massachusetts (excluding conflict of law rules). Any legal action regarding this Agreement will be heard in the state or federal courts having jurisdiction in Suffolk County, Massachusetts, and Customer hereby 
submits to the personal jurisdiction and venue of such courts. The United Nations Convention on Contracts for the International Sale of Goods shall not apply to this Agreement and is expressly disclaimed. 

©2016 Analog Devices, Inc. All rights reserved. Trademarks and   
registered trademarks are the property of their respective owners. 
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